Accéder au contenu principal

Exercice langage C: palindrome N°1

 


Exercice

écrire un programme en c poor vérifie si une chaine a palindrom est une chaine qui se lit aussi bien à l'envers qu'à l'endroit.
Exemple

Correction

Commentaires

  1. Casinos Near Harrah's Philadelphia - Mapyro
    Find 경산 출장마사지 Casinos Near Harrah's Philadelphia in Chester, PA, United States 이천 출장마사지 - 수원 출장샵 Mapyro® delivers 군산 출장샵 high-quality real-time casino real-time 전라남도 출장샵 casino information to your

    RépondreSupprimer

Enregistrer un commentaire

Posts les plus consultés de ce blog

Exercices Algorithme: les fonctions et les procedures N°2

Exercice 1: Ecrire une fonction ou procédure qui affiche tous les nombres pairs compris entre deux valeurs entières positives lue x et y correction Procedure calcul ; Declaration Variable x, y, z : entier ; Debut Lire (x, y); Si x > y Alors Debut z <-- x ; x <-- y ; y <-- z ; Fin FinSi ; Tantque x ≤ y Faire Si x mod 2 = 0 Alors Ecrire (x) FinSi ; x <-- x + 1 FinTantque Fin ; Exercice 2: Ecrire une fonction ou procédure qui permet d’entrer la date d’aujourd’hui puis demande le nom de la personne ; si ce nom = Ahmed il y a affichage de "Bienvenue Ahmed » puis lui demande sa date d’anniversaire et la compare à la date d’aujourd’hui si c’est

Exercices Algorithme :les fonctions et les procedures N°1

Exercice 1: Ecrire une fonction ou procédure qui calcule la partie entière d’un nombre positif correction Fonction entiere (x : reel) : entier ; Declaration Variable y : entier ; Debut y <-- 0 ; Tantque y < x faire y <-- y + 1 FinTanque ; entiere <-- y Fin ; Exercice 2: Ecrire une fonction ou procédure qui affiche le tableau de multiplication d’un entier positif x. correction Procedure Multipl (x: entier) ; Declaration Variable a, b : entier ; Debut b <-- 0 ; Pour a <-- 1 a 10 faire Debut b <-- b + x Ecrire (x, ‘X’, a, ‘= ‘, b) ; Fin FinPour fin; Exercice 3: Ecrire une fonction ou procé

Exercices Algorithme les tableaux

Les tableaux a une dimension Exercice 1: Ecrire un algorithme qui déclare et remplisse un tableau de 7 valeurs numériques en les mettant toutes à zéro. Correction Tableau Truc(6) en Numérique Variable i en Numérique Debut Pour i ← 0 à 6 Truc(i) ← 0 FinPour Fin Exercice 2: Ecrire un algorithme qui déclare et remplisse un tableau contenant les six voyelles de l’alphabet latin. Correction Tableau Truc(5) en Caractère Debut Truc(0) ← "a" Truc(1) ← "e" Truc(2) ← "i" Truc(3) ← "o" Truc(4) ← "u" Truc(5) ← "y" Fin Exercice 3: Ecrire un algorithme qui déclare un tableau de 9 notes, dont on fait ensuite saisir les valeurs par l’utilisateur. Correction Tableau Notes(8) en Numérique Variable i en Numérique Debut Pour i ← 0 à 8 Ecrire "Entrez la note numéro ", i + 1 Lire Notes(i) FinPour Fin Exercice 4: Que produit l’algorith