Accéder au contenu principal

Exercice javascript: les bases N°1

 


Exercice 1

inversez la chaine fournie , Vous devrez peut-être transformer la chaîne en un tableau avant de pouvoir l'inverser.
Exemple

Correction


function inverseChaine(chaine)
{
    var res ="";
     for(var i=chaine.length -1 ;i >=0 ;i--)
     {
        res+=chaine[i];
     }
          return res;
}  
 inverseChaine('Bonjour');

Exercice 2

Renvoyez la longueur du mot le plus long dans la phrase donnée.Votre réponse doit être un numéro.
Exemple

Correction


function TrouverLeMot(chaine)
{
    var arr = [];
    arr = chaine.split(' ');
    var res = arr[0].length;
    for(var i=1;i <= arr[i].length;i++)
    {
        if(res <= arr[i].length)
        {
            res = arr[i].length;
        }
    }
    return res;
}
TrouverLeMot('Bonjour tout le monde');
         

Exercice 3

Retournez un tableau composé du plus grand nombre de chaque sous-tableau fourni. pour plus de simplicité, le tableau indiqué 3 sous-tableaux exactement.
Exemple

Correction


function PlusGrand(arr) 
{
    var res=[];
    for(var i=0; i < 3 ;i++)
    {
    var check = arr[i][0];
    for(var j=0; j < arr[i].length;j++)
    {
        if (check <= arr[i][j] )
        {
        check = arr[i][j];
        }
    }
    res.push(check);
    }
    return res;
}  
      PlusGrand([[4, 5, 1, 3], [13, 27, 18, 26], [32, 35, 37, 39]]);    


Exercice 4

Vérifiez si une chaîne (premier argument, ch) se termine par la chaîne cible donnée (deuxième argument, cible). utiliser la methode substring pour confirmer.
Exemple

Correction

    
function confirmerLaFin(ch, cible) 
{
  var l=ch.length - 1;
  var l2=cible.length -1;
  var res = l - l2;
    if(ch.substring(res) == cible)
    {
     return true;
    }
   return false;
        
} 
confirmerLaFin("ce soir", "soir");

    

Exercice 5

Répétez une chaîne de caractères donnée chaine (premier argument) pour un nombre de fois (deuxième argument). Renvoyer une chaîne vide si num n'est pas un nombre positif.

Correction

    
function RepeterChaineNombreFois(chaine, nbr) 
{
    var res ="";
    if(nbr > 0)
    {
        for(var i = 0 ; i < nbr;i++)
        {
            res +=chaine;
        }
    }

    return res;
}      
RepeterChaineNombreFois("akc", 2);

    

Posts les plus consultés de ce blog

Exercices Algorithme: les fonctions et les procedures N°2

Exercice 1: Ecrire une fonction ou procédure qui affiche tous les nombres pairs compris entre deux valeurs entières positives lue x et y correction Procedure calcul ; Declaration Variable x, y, z : entier ; Debut Lire (x, y); Si x > y Alors Debut z <-- x ; x <-- y ; y <-- z ; Fin FinSi ; Tantque x ≤ y Faire Si x mod 2 = 0 Alors Ecrire (x) FinSi ; x <-- x + 1 FinTantque Fin ; Exercice 2: Ecrire une fonction ou procédure qui permet d’entrer la date d’aujourd’hui puis demande le nom de la personne ; si ce nom = Ahmed il y a affichage de "Bienvenue Ahmed » puis lui demande sa date d’anniversaire et la compare à la date d’aujourd’hui si c’est

Exercices Algorithme :les fonctions et les procedures N°1

Exercice 1: Ecrire une fonction ou procédure qui calcule la partie entière d’un nombre positif correction Fonction entiere (x : reel) : entier ; Declaration Variable y : entier ; Debut y <-- 0 ; Tantque y < x faire y <-- y + 1 FinTanque ; entiere <-- y Fin ; Exercice 2: Ecrire une fonction ou procédure qui affiche le tableau de multiplication d’un entier positif x. correction Procedure Multipl (x: entier) ; Declaration Variable a, b : entier ; Debut b <-- 0 ; Pour a <-- 1 a 10 faire Debut b <-- b + x Ecrire (x, ‘X’, a, ‘= ‘, b) ; Fin FinPour fin; Exercice 3: Ecrire une fonction ou procé

Exercices Algorithme les tableaux

Les tableaux a une dimension Exercice 1: Ecrire un algorithme qui déclare et remplisse un tableau de 7 valeurs numériques en les mettant toutes à zéro. Correction Tableau Truc(6) en Numérique Variable i en Numérique Debut Pour i ← 0 à 6 Truc(i) ← 0 FinPour Fin Exercice 2: Ecrire un algorithme qui déclare et remplisse un tableau contenant les six voyelles de l’alphabet latin. Correction Tableau Truc(5) en Caractère Debut Truc(0) ← "a" Truc(1) ← "e" Truc(2) ← "i" Truc(3) ← "o" Truc(4) ← "u" Truc(5) ← "y" Fin Exercice 3: Ecrire un algorithme qui déclare un tableau de 9 notes, dont on fait ensuite saisir les valeurs par l’utilisateur. Correction Tableau Notes(8) en Numérique Variable i en Numérique Debut Pour i ← 0 à 8 Ecrire "Entrez la note numéro ", i + 1 Lire Notes(i) FinPour Fin Exercice 4: Que produit l’algorith