Accéder au contenu principal

Exercices corrigé en Algorithme (les bases)

 


Exercice 1

ecrire algorithme permettant d'effectuer des opérations arithmétiques de base d'addition, de soustraction, de multiplication et de division de deux nombres
Exemple:

Correction

    
Algorithme arithmétiques 
variable a,b,res1,res2,res3,res4:entier
Debut
  ecrire("tpaez deux nombres ");
  lire(a,b);   //lire(a);lire(b)
  res1 <-- a + b;
  res2 <-- a - b;
  res3 <-- a * b;
  res4 <-- a / b;
  ecrire("somme =",res1);
  ecrire("soustraction =",res2);
  ecrire("multiplication =",res3);
  ecrire("division =",res4);
Fin
    

Exercice 2

Somme de n nombres . cet algorithme ajoute n chiffres qu'un utilisateur saisait. L'utilisateur saisit un nombre indiquant le nombre de chiffres à ajouter .
Exemple

Correction

    
Algorithme Somme_de_N
variable n:entier 
         i:entier
         som:entier
         valeur:entier 
Debut
   som <-- 0;
   ecrire("Combien de chiffres vous voulez ajouter");
   lire(n);
   pour i <-- 0 a n-1 faire
     lire(valeur);
     som <-- som + valeur ;
   Finpour
   ecrire("somme des entiers est:",som); 
Fin;
    

Exercice 3

ecrire une programe que vérifie l'entrer d'utilisateur est voyelle ou no. les voyelles est : 'a','e','i','o','u'

Correction

    
 Algorithme voyelle
 variable mot:chaine;
  Debut
   ecrire("entrer le caractère");
    lire(mot);
    Si mot = 'a' ou mot = 'e' ou mot = 'i' ou mot = 'o' ou mot = 'u'
     Debut
      ecrire("ce mot est voyelle");
     Fin
    sinon 
     ecrire("ce n'est pas une voyelle") ;
    FinSi
  Fin       
    

Exercice 4

Retourne le factoriel de l'entier fourni. Si l'entier est représenté par la lettre n, une factorielle est le produit de tous les entiers positifs inférieurs ou égaux à n. Les factoriels sont souvent représentés par la notation sténographique n!.
Exemple

Correction

    
Algorithme factoriel
variable  x:entier;
          i:entier;
          n:entier;
Debut
   ecrire('tapez un nombre positive :');
   lire(n);
   x <-- 1;
   pour i <-- 2 a n faire 
    Debut
     x <-- x * i;
    Fin
   Finpour 
    ecrire('le factoriel de ',n,'est egal 'x);
Fin
    

Exercice 5

ecrire une algorithme qui calcule le PGCD et PPCM de deux entiers strictement positifs.
Exemple

Correction

    
        //methode 1
Algorithme PGCD_PPCM
variable a:entier 
         b:entier 
         PGCD:entier 
         PPCM:entier 
Debut
    ecrire("tapez deux nombre entier");
    lire(a,b);  //lire(a) lire(b)
    Tantque (a * b <> 0) Faire
        Si a > b Alors
         a <-- a - b;
         Sinon
         b <-- b - a ;
        FinSi
    FinTantque ;
        Si a = 0 alors
         PGCD <-- b
         Sinon
         PGCD <-- a
        FinSi
     PPCM <-- a * b Div PGCD;
     ecrire("le plus grand commun diviseur est :",PGCD);
     ecrire("le plus petite commun multipe est :",PPCM);
Fin;

     //methode 2
Algorithme PGCD_PPCM
variable a ,b ,x ,y ,t ,PGCD ,PPCM :entier 
Debut
  ecrire("tapez deux entier positife");
  lire(a,b);
  x <-- a;
  y <-- b;
 Tantque (b <> 0) faire
   t <-- a;
   b <-- a Mod b;
   a <-- t;
 FinTantque
  PGCD <-- a;
  PPCM <-- a * b Div PGCD;
  ecrire("le plus grand commun diviseur est :",PGCD);
  ecrire("le plus petite commun multipe est :",PPCM);
Fin;
    

Commentaires

  1. Merkur 34C Long Handle DE Safety Razor - Curio
    Merkur 34C Long Handle DE Safety Razor - Curio. The Merkur 34C Heavy Duty Safety Razor is 메리트카지노 crafted in chrome, black finished in chrome, Handle length: 90 mmWeight: หาเงินออนไลน์ 110.62 메리트 카지노 grBlade diameter: 82 mm€45.99 · ‎In stock

    RépondreSupprimer
  2. The 10 Best Casinos With Instant Payout
    If you are new to this casino then you casino-roll.com can bet that septcasino.com this is a game-changing, https://vannienailor4166blog.blogspot.com/ regulated and safe online novcasino casino. For starters, the games you have 토토 사이트 to

    RépondreSupprimer

Enregistrer un commentaire

Posts les plus consultés de ce blog

Exercices Algorithme: les fonctions et les procedures N°2

Exercice 1: Ecrire une fonction ou procédure qui affiche tous les nombres pairs compris entre deux valeurs entières positives lue x et y correction Procedure calcul ; Declaration Variable x, y, z : entier ; Debut Lire (x, y); Si x > y Alors Debut z <-- x ; x <-- y ; y <-- z ; Fin FinSi ; Tantque x ≤ y Faire Si x mod 2 = 0 Alors Ecrire (x) FinSi ; x <-- x + 1 FinTantque Fin ; Exercice 2: Ecrire une fonction ou procédure qui permet d’entrer la date d’aujourd’hui puis demande le nom de la personne ; si ce nom = Ahmed il y a affichage de "Bienvenue Ahmed » puis lui demande sa date d’anniversaire et la compare à la date d’aujourd’hui si c’est

Exercices Algorithme :les fonctions et les procedures N°1

Exercice 1: Ecrire une fonction ou procédure qui calcule la partie entière d’un nombre positif correction Fonction entiere (x : reel) : entier ; Declaration Variable y : entier ; Debut y <-- 0 ; Tantque y < x faire y <-- y + 1 FinTanque ; entiere <-- y Fin ; Exercice 2: Ecrire une fonction ou procédure qui affiche le tableau de multiplication d’un entier positif x. correction Procedure Multipl (x: entier) ; Declaration Variable a, b : entier ; Debut b <-- 0 ; Pour a <-- 1 a 10 faire Debut b <-- b + x Ecrire (x, ‘X’, a, ‘= ‘, b) ; Fin FinPour fin; Exercice 3: Ecrire une fonction ou procé

Exercices Algorithme les tableaux

Les tableaux a une dimension Exercice 1: Ecrire un algorithme qui déclare et remplisse un tableau de 7 valeurs numériques en les mettant toutes à zéro. Correction Tableau Truc(6) en Numérique Variable i en Numérique Debut Pour i ← 0 à 6 Truc(i) ← 0 FinPour Fin Exercice 2: Ecrire un algorithme qui déclare et remplisse un tableau contenant les six voyelles de l’alphabet latin. Correction Tableau Truc(5) en Caractère Debut Truc(0) ← "a" Truc(1) ← "e" Truc(2) ← "i" Truc(3) ← "o" Truc(4) ← "u" Truc(5) ← "y" Fin Exercice 3: Ecrire un algorithme qui déclare un tableau de 9 notes, dont on fait ensuite saisir les valeurs par l’utilisateur. Correction Tableau Notes(8) en Numérique Variable i en Numérique Debut Pour i ← 0 à 8 Ecrire "Entrez la note numéro ", i + 1 Lire Notes(i) FinPour Fin Exercice 4: Que produit l’algorith